Saturday 28 December 2013

solaris 11 ZONES DEDICATED CPU assignment (only dedicated cpus are visible)

1)to see installed zones
root@solaris2:~# zoneadm list -i
global
testzone
2)to see configured zones
root@solaris2:~# zoneadm list -c
global
testzone
3)to see macine prsable output ( help full in SHELL script)
root@solaris2:~# zoneadm list -p
0:global:running:/::solaris:shared:-:none
8:testzone:running:/TESTZONE:b61dfe4d-24eb-6f97-eac6-b4e9f637a02b:solaris:excl:-:
4)to list configured zone information
root@solaris2:~# zoneadm list -v
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              solaris  shared
   8 testzone         running    /TESTZONE                      solaris  excl
root@solaris2:~# zoneadm -z testzone halt
root@solaris2:~# zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              solaris  shared
   - testzone         installed  /TESTZONE                      solaris  excl

5)Dedicated cup assignment removing capped cpu & assigning Dedicated Cpus.
root@solaris2:~# zonecfg -z testzone
zonecfg:testzone> info
zonename: testzone
zonepath: /TESTZONE
brand: solaris
autoboot: true
bootargs:
file-mac-profile:
pool:
limitpriv:
scheduling-class:
ip-type: exclusive
hostid:
fs-allowed:
net:
        address not specified
        allowed-address not specified
        configure-allowed-address: true
        physical: net3
        defrouter not specified
capped-cpu:
        [ncpus: 4.00]
capped-memory:
        physical: 4G
        [swap: 1G]
        [locked: 100M]
rctl:
        name: zone.cpu-cap
        value: (priv=privileged,limit=400,action=deny)
rctl:
        name: zone.max-swap
        value: (priv=privileged,limit=1073741824,action=deny)
rctl:
        name: zone.max-locked-memory
        value: (priv=privileged,limit=104857600,action=deny)
zonecfg:testzone> remove capped-cpu
zonecfg:testzone> info
zonename: testzone
zonepath: /TESTZONE
brand: solaris
autoboot: true
bootargs:
file-mac-profile:
pool:
limitpriv:
scheduling-class:
ip-type: exclusive
hostid:
fs-allowed:
net:
        address not specified
        allowed-address not specified
        configure-allowed-address: true
        physical: net3
        defrouter not specified
capped-memory:
        physical: 4G
        [swap: 1G]
        [locked: 100M]
rctl:
        name: zone.max-swap
        value: (priv=privileged,limit=1073741824,action=deny)
rctl:
        name: zone.max-locked-memory
        value: (priv=privileged,limit=104857600,action=deny)

The 'dedicated-cpu' resource scope configures the 'pools' facility to dedicate
a subset of the system'sprocessors to this zone while it is running.


zonecfg:testzone> add dedicated-cpu
zonecfg:testzone:dedicated-cpu> info
dedicated-cpu:
        ncpus:
zonecfg:testzone:dedicated-cpu> set ncpus=4
zonecfg:testzone:dedicated-cpu> set importance=1
zonecfg:testzone:dedicated-cpu> end
zonecfg:testzone> info
zonename: testzone
zonepath: /TESTZONE
brand: solaris
autoboot: true
bootargs:
file-mac-profile:
pool:
limitpriv:
scheduling-class:
ip-type: exclusive
hostid:
fs-allowed:
net:
        address not specified
        allowed-address not specified
        configure-allowed-address: true
        physical: net3
        defrouter not specified
dedicated-cpu:
        ncpus: 4
        importance: 1
capped-memory:
        physical: 4G
        [swap: 1G]
        [locked: 100M]
rctl:
        name: zone.max-swap
        value: (priv=privileged,limit=1073741824,action=deny)
rctl:
        name: zone.max-locked-memory
        value: (priv=privileged,limit=104857600,action=deny)

zonecfg:testzone> verify
zonecfg:testzone> commit
zonecfg:testzone> exit

6)to list configured zone status
root@solaris2:~# zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              solaris  shared
   - testzone         installed  /TESTZONE                      solaris  excl
root@solaris2:~# zoneadm -z testzone boot
root@solaris2:~# zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              solaris  shared
   9 testzone         running    /TESTZONE                      solaris  excl

root@solaris2:~# zlogin testzone
[Connected to zone 'testzone' pts/2]
Oracle Corporation      SunOS 5.11      11.1    May 2013
root@testzone:~# psrinfo
0       on-line   since 12/27/2013 23:12:07
1       on-line   since 12/27/2013 23:12:09
2       on-line   since 12/27/2013 23:12:09
3       on-line   since 12/27/2013 23:12:09

No comments:

Post a Comment